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The IDL Intelligent Tools (iTools) 
 

The IDL Intelligent Tools (iTools) are a set of interactive utilities that combine data 

analysis and visualization with the ability to produce presentation quality graphics.  

The iTools allow users to continue to benefit from the control of a programming 

language, while enjoying the convenience of a point-and-click environment.  There 

are 7 primary iTool utilities built into the IDL software package.  Each of these seven 

tools is designed around a specific data or visualization type : 

 

• Two and three dimensional plots (line, scatter, polar, and histogram style) 

• Surface representations 

• Contours 

• Image displays 

• Mapping 

• Two dimensional vector flow fields 

• Volume visualizations 

 

The iTools system is built upon an object-oriented component framework 

architecture that is actually comprised of only a single tool, which adapts to handle 

the data that the user passes to it.  The pre-built iPlot, iSurface, iContour, iMap, 

iImage, iVector and iVolume procedures are simply shortcut configurations that 

facilitate ad hoc data analysis and visualization.  Each pre-built tool encapsulates the 

functionality (data operations, display manipulations, visualization types, etc.) 

required to handle its specific data type.  However, users are not constrained to work 

with a single data or visualization type within any given tool.  Instead, using the 

iTools system a user can combine multiple dataset visualization types into a single 

tool creating a hybrid that can provide complex, composite visualizations. 

 

 

 

Starting the iPlot Intelligent Tool and Loading Data 
 

Launch the iPlot utility by executing the procedure iPlot at the IDL> command 

prompt : 

 

1. IDL> iPlot 

 

A splash screen will appear while the iTools system is launching.  The first time the 

iTools system is launched in any given session of IDL will always be the slowest since 

the iTools need to be compiled from their ASCII text source code files found in the 

“lib/itools/” subfolder of the IDL distribution (i.e. the user has access to the source 

code for the entire iTools system).  Once the iTools system is up and running a 

separate window will come up entitled “IDL iPlot”.  Feel free to minimize the IDLDE 

window as the next steps of this exercise will involve the iPlot utility. 

 

In the following exercise, the time-series data from the example data file 

“time_series.txt” will be input into the iPlot utility.  This example data file is located 

in the “data” subfolder. 
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The file “time_series.txt” contains standard ASCII text consisting of 4 columns of 

data separated by whitespace.  The first column contains the time-stamp data 

(independent variable), and the rest of the columns contain various data 

measurements made at the associated time (dependent variables).  Here are the 

first 4 lines of this ASCII text file : 

 
    Time     Data1        Data2        Data3 
       0     0.638570     0.721137     0.498828 
       1     0.638366     0.721189     0.503347 
       2     0.637349     0.720877     0.505433 

 

There are a number of different ways to load data into an iTool, and probably the 

easiest of these is to use the data input utilities built into the iTools system. 

 

2. Select “File > Open…” from the IDL iPlot window. 

3. Navigate to the location of the “time_series.txt” file, select it, and hit “Open”. 

4. This will launch the ASCII Template wizard [Fig. 1] that will guide the user 

through the steps of defining the layout of the data within the file. 

5. Change the “Data Starts at Line:” field to 2 so the first line of column headers 

is skipped during the read process [Fig. 1]. 

6. Hit the “Next >>” button to proceed to step 2. 

7. In Step 2 of 3 make sure all of the parameters match the default settings 

illustrated in Fig. 2. 

8. Hit the “Next >>” button to proceed to step 3. 

9. In Step 3 of 3 change the name of the fields to match the column headers 

above.  This can be accomplished by clicking on the columns in the “Sample 

Record:” area and typing the appropriate text into the “Name:” field [Fig. 3]. 

10. Hit “Finish” to complete the ASCII Template wizard. 
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Figure 1: Step 1 of 3 for the ASCII Template wizard 

 

 
 

Figure 2: Step 2 of 3 for the ASCII Template wizard 
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Figure 3: Step 3 of 3 for the ASCII Template wizard 

 

Once the user is finished running the ASCII Template wizard the IDL iTools Create 

Visualization dialog will come up [Fig. 4]. 

 

 
 

Figure 4: The IDL iTools Create Visualization dialog 

 

11. In order to create a line plot visualization out of the time-series data, press 

“Select a visualization and specify parameters” and hit “OK”. 

 

This will bring up the iTools Insert Visualization dialog.  This tool is used to select the 

data that is used to create the line plot visualization.  In this case, there is one 

independent variable (X) contained in the field “time_series.TIME”, and 3 dependent 

variables (Y) that can be plotted as a function of this time. 

 

12. Click on the “time_series” item within the Data Manager panel and expand. 

13. Select the “X” row in the lower left table and then double-click the 

“time_series.TIME” field from the upper left window to insert the time-stamp 

data as the independent variable [Fig. 5]. 

14. Select the “Y” row in the lower left table and then double-click the 

“time_series.DATA1” field from the upper left window to insert the first data 

measurement as the dependent variable [Fig. 5]. 

15. Once these selections have been made, press “OK”. 
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Figure 5: The iTools Insert Visualization dialog 

 

A simple line plot of the “Time” data (X axis) versus the “Data1” data (Y axis) will 

appear within the IDL iPlot window [Fig. 6].  Notice that both the X and Y axes have 

been automatically scaled to display the full data range of the respective variables.  

Currently the size of the IDL iPlot window should be the default when it was first 

launched, which makes it difficult to visualize the features within the line plot 

graphic.  Consequently, use the following steps to maximize the visual area for the 

graphics window : 

 

16. From the IDL iPlot window menu select “Window > Zoom on Resize”. 

17. Hit the maximize button  in the upper-right hand corner of the window. 
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Figure 6: The IDL iPlot window displaying graphic of time-series data 

 

Currently the line plot should be displayed with the default black color.  Furthermore, 

the iPlot tool should be in selection mode with the line plot automatically selected 

(graphic will be surrounded by 8 small squares and highlighted with cyan color 

markers).  If the line plot is not selected simply click on the line in any location so it 

appears as displayed in Fig. 6.  In order to differentiate the line plot from the axes 

(and the other data variables which will soon be plotted) change the color to red by 

following these steps : 

 

18. Right-click on the lineplot in order to see the standard iTools context menu. 

19. Select “Properties…”. 

20. Within the IDL iPlot: Visualization Browser window, click on the box to the 

right of the “Color” property and select bright red [Fig. 7]. 

21. Once the desired change has been made, close the IDL iPlot: Visualization 

Browser window. 
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Figure 7: The IDL iPlot: Visualization browser window (property sheet) 

 

Now that the line plot for the first dataset has been changed in color to red, the two 

remaining dependent data variables can be imported an overplotted within the 

existing visualization : 

 

22. From the IDL iPlot window menu system, select “Insert > Visualization…”. 

23. Select the “Y” row in the lower left table and this time double-click the 

“time_series.DATA2” field from the upper left window to insert the second 

data measurement as the dependent variable. 

24. Once this has been accomplished, hit “OK”. 

 

This will automatically insert a new lineplot within the existing data space and axes.  

Once again the line is plotted with the default black color, so use the following steps 

to change the color of this line to blue : 

 

25. Select the new black line plot if it is not already (it should be selected by 

default). 

26. Right-click, select “Properties…”, and change the “Color” property to blue. 

27. Close the IDL iPlot: Visualization Browser window. 

 

Next, plot the third and final data variable and change its line color to green : 

 

28. From the IDL iPlot window menu system, select “Insert > Visualization…”. 

29. This time select the “Y” row in the lower left table and then double-click the 

“time_series.DATA3” field from the upper left window to insert the second 

data measurement as the dependent variable. 

30. Once this has been accomplished, hit “OK”. 

31. Select the new black line plot. 

32. Right-click, select “Properties…”, and change the “Color” property to green. 
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33. Close the IDL iPlot: Visualization Browser window. 

 

Notice that when this final data variable was plotted, the scaling of the Y axis 

automatically changed in order to display the full data range of all 3 time-series 

measurements.  In addition, dashed lines that are cyan in color will be displayed 

when a specific line plot is selected, which mark the minimum and maximum Y data 

range for that dataset.  The line plot visualization should now look like Fig. 8. 

 

 
 

Figure 8: The line plot visualization of all 3 time-series datasets 

 

Now that all 3 time-series datasets have been loaded and plotted, it is a good idea to 

save the current state of the iPlot visualization utility.  When an iTool is saved, the 

state of the utility in its entirety is output to a file on disk, and this state includes the 

layout of the current graphical visualizations, their properties, and the data itself.  

Use the following steps to save the current iTool state : 

 

34. From the IDL iPlot window, select “File > Save As…”. 

35. Save the iTools state to a new file named “line_plots.isv”. 

36. Press the “Save” button. 
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Figure 9: Saving the iTool state to a file on disk 

 

 

 

Selection of Objects, Undo/Redo, and Manipulation 
 

The iTools graphical system is based on an object-oriented architecture where each 

element (graphic, display window, axes, annotations, etc.) have individual objects 

associated with them.  These objects each have their own individual properties, 

such as the color of the line plots that were modified in the previous exercise.  The 

power of an object-oriented architecture is that separate objects can be built into a 

hierarchy that provides the ability to create complex graphical visualizations. 

 

There are three ways to select separate or multiple objects within the iTools system : 

 

• Using the Select/Translate arrow manipulator 

• Using the Visualization Browser window 

• Selecting “Edit > Select All” from the iTool menu system 

 

Experiment with selecting separate graphical objects or groups of objects using the 

Select/Translate arrow : 

 

1. If necessary, click the Select/Translate arrow button  on the toolbar to 

enter the object selection and translation manipulator mode. 
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2. Position the mouse cursor pointer over one of the line plots and click with the 

left mouse button.  The line plot object will be highlighted with cyan markers, 

and a selection box will appear around the data space. 

3. To select additional line plots, hold down the Shift key on the keyboard while 

clicking them. 

4. The arrow button manipulator also provides translation functionality.  While at 

least one of the line plots is selected, click and hold down the left mouse 

button while moving the mouse to re-position the data space within the view 

window.  The mouse pointer changes to the translation pointer . 

5. In addition to being able to select and move the line plots, the axes are also 

their own individual objects.  Click on one of the axes to select it, then hold 

down the left mouse button to move it within the view window.  Each axis can 

be moved in a plane perpendicular to its direction. 

6. Also experiment with the ability to click-and-drag an object selection box.  

This can be accomplished by clicking in the white area outside of the data 

space, holding down the mouse button, and dragging a rectangular box.  

Once the mouse button is released, any objects that fall within the selected 

region in their entirety will be selected and highlighted. 

 

If at any time an action is taken within an iTool that the user wishes to reverse, they 

can utilize the built-in Undo/Redo system.  There are two ways to access the 

Undo/Redo mechanism within any given iTool : 

 

• Using the Undo/Redo  buttons on the toolbar 

• From the Edit menu system 

 

7. Experiment with the Undo/Redo system using both the toolbar buttons and 

the Edit menu system items in order to retrace and repeat the steps that 

have been performed within the current IDL iPlot utility. 

8. Using the Select/Translate arrow or the Undo/Redo system, setup the current 

visualization in its previous appearance with the data space centered within 

the view window. 

9. While in Select/Translate mode, click in an area outside of the data space so 

that no object appears selected. 

10. Open the Visualization Browser window by selecting “Window > Visualization 

Browser…” from the menu system. 

 

The Visualization Browser window displays the object-oriented hierarchy of the 

current graphical visualization for the iTool on the left-hand side, and the property 

sheet for the currently selected object on the right-hand side [Fig. 10].  Currently 

the main view object named “View_1” should be selected, which is the white 

graphics area within the IDL iPlot window. 

 

11. Experiment with selecting various objects on the left-hand side of the 

Visualization Browser window. 

 

Notice how the objects are once again highlighted within the IDL iPlot utility window 

when they are selected.  In addition, notice how the property sheet on the right-

hand side of the Visualization Browser window updates to reflect the properties of 

the currently selected object. 
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Currently the 3 line plot graphical objects that are contained within the iTool are 

named “Plot”, “Plot 0”, and “Plot 1” by default [Fig. 10].  These line plot objects can 

be given more appropriate names that help associate them with the data they are 

displaying. 

 

 
 

Figure 10: The Visualization Browser window 

 

12. Click on the first line plot object named “Plot” within the Visualization Browser 

window. 

13. On the right-hand side, change the “Name” property to the appropriate time-

series field name from the original dataset “Data1”.  It may help to expand 

the plot object tree to look at the parameters (data) that define the graphical 

object [Fig. 11]. 

14. Make sure to hit the Enter key on the keyboard after modifying the “Name” 

property so the change takes effect. 

15. Repeat this process for the other 2 line plot objects, changing “Plot 0” to 

“Data2”, and “Plot 1” to “Data3” [Fig. 11]. 

16. The final state of the Visualization Browser window should look like Fig. 11.  

Once this has been accomplished close the Visualization Browser window. 

 

In addition to the translation manipulator mode accessed via the Select/Translate 

arrow button, there is also Rotate, View Zoom, Scaling, and Data Range 

manipulators that can be accessed using their respective buttons on the toolbar : 

 

17. From the IDL iPlot window menu system, select “Edit > Select All”. 

18. Click the Rotate  button to enter rotation manipulator mode. 

19. Experiment with arbitrarily rotating the current graphic by clicking on it, 

holding down the mouse button, and moving the mouse. 

20. Notice how the arrow keys on the keyboard can also be used to rotate the 

graphic (after it has been rotated by the mouse).  Furthermore, notice how 

using the Shift and Ctrl keys in conjunction with the arrow keys will rotate the 

graphic by specific amounts. 
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21. Since the rotation of line plot graphics is usually not appropriate, use either 

the Ctrl-arrow button single degree rotation or the Undo button to restore the 

visualization to its original horizontal orientation. 

 

 
 

Figure 11: Changing the Name properties of the 3 line plot objects 

 

The size of the graphics area can also be made smaller / larger in relation to the 

display canvas by using the View Zoom manipulator : 

 

22. Click the Zoom  button to enter View Zoom manipulator mode. 

23. Position the mouse pointer over the viewplane.  The pointer will change to a 

zoom pointer. 

24. The view zoom manipulator works by clicking-and-dragging with the mouse 

cursor.  Dragging the zoom pointer towards the top of the window (upwards 

direction) will enlarge the graphics.  Dragging the zoom pointer towards the 

bottom of the window (downwards direction) will make the graphics area 

smaller. 

25. Restore the graphics area (approximately) to its original size, and click on the 

Select/Translate  arrow button in order to leave View Zoom mode. 

 

In addition to using the View Zoom manipulator tool, the size of the graphics area 

can also be made smaller / larger using the constrained and unconstrained scaling 

available when using the Select/Translate arrow mode.  Constrained scaling permits 

changing the size of only one dimension while preserving the size of the other 

dimensions.  In contrast, unconstrained rotation allows the user to scale all 

dimensions of an object in an arbitrary fashion. 

 

26. While using the Select/Translate arrow mode, click on one of the line plots 

within the graphics area. 
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27. In addition to the selected line plot being highlighted with cyan color markers, 

the 8 green selection boxes will appear around the graphics area. 

28. To perform constrained scaling, position the mouse cursor over one of the 

four selection boxes found midway along each side of the graphics area.  The 

mouse cursor will change to a double-headed  arrow. 

29. Click-and-drag with the mouse to scale the graphics in the desired direction. 

30. To perform unconstrained scaling, position the mouse cursor over one of the 

four selection boxes found in the corners of the graphics area.  The mouse 

cursor will change to a four-headed  arrow. 

31. Click-and-drag with the mouse to scale the graphics in an unconstrained 

fashion. 

32. Restore the graphics area (approximately) to its original shape and size. 

 

Finally, the Data Range tool allows the user to zoom into the data space itself, 

instead of simply resizing the graphics area within the viewplane.  This allows users 

to adjust the range displayed within the current graphics area, and zoom into the 

data space to get a better look at features at a smaller scale. 

 

33. While one or all of the line plots are selected, click the Data Range  button 

to enter data range manipulator mode. 

34. Both the X and Y axes will be labeled with green translation arrows and zoom 

symbols (“+” and “-”).  Clicking on these will change the range and location 

of the respective axis. 

35. In addition, position the mouse cursor within the graphics area containing the 

line plots.  The mouse cursor will change to a cross-hair. 

36. Click-and-drag to define a rectangular box within the graphics area, and once 

the box has been defined release the mouse button to zoom into the 

corresponding data range. 

37. Select/Translate  arrow button in order to leave Data Range mode. 

38. In order to reset the data range to the original full extent of all 3 data 

variables, select “Window > Reset Dataspace Ranges” from the IDL iPlot 

window menu system. 

 

 

 

Labeling Axes, Annotation, and Inserting a Legend 
 

Currently the line plots for the 3 time-series data variables are displayed with 

different colors, but there are no annotations present within the visualization window 

that describe the contents of the graphic.  In order to label the axes and change the 

direction of the tick marks, utilize the Visualization Browser window : 

 

1. Select “Window > Visualization Browser…”. 

2. Expand the Axes group to see the 4 separate axis objects. 

3. Select the first axis object named “Axis 0”.  Notice that the bottom X-axis 

within the iPlot window is highlighted. 

4. Scroll down the property sheet on the right-hand side and locate the “Title” 

property.  Change the “Title” property for this axis to “Time-Stamp (seconds 

elapsed)” and hit Enter on the keyboard to complete the change [Fig. 12]. 
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Figure 12: Modification of the Title property for the X axis 

 

5. Next, select the second axis object named “Axis 2”.  This selects the Y axis 

along the left-hand side of the graphics area. 

6. Find the “Tick direction” property, click within the setting box, and change the 

droplist to “Left/Below”. 

7. Once again, scroll down and change the “Title” property to “Data Values”. 

8. Finally, select the last axis named “Axis 3” and change the “Tick direction” 

property to “Right/Above”. 

9. Once these tasks have been accomplished, close the Visualization Browser 

window. 

10. An axis may still be selected, so click in the white viewplane outside of the 

graphics area to unselect all graphical objects. 

 

It may also be appropriate to provide a title for the overall visualization, and this can 

be inserted into the visualization using the Text annotation tool : 

 

11. Click the Text  annotation button to enter text insertion mode. 

12. Once the mouse cursor is moved over the viewplane, the pointer will change 

to a standard text selection cursor. 

13. Click on a location outside and above the graphics area.  A cursor is inserted 

into the annotation layer and text insertion mode is initiated. 

14. Using the keyboard, enter the text “Time-Series Line Plots”.  Once finished 

typing this text, hit the Enter key to complete the text annotation. 

15. While this text annotation object is highlighted, right-click on it and select 

“Properties…” from the context menu. 

16. The font properties of this text annotation can be modified to make it appear 

like a legitimate graphics title.  In the Visualization Browser window, change 

the “Text font” property to “Times”. 

17. Change the “Text style” property to “Bold”. 
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18. Change the “Text font size” to “16”, hit Enter, and close the Visualization 

Browser window. 

19. Re-position the text annotation so it is centered above the graphics area. 

 

Finally, a legend can be inserted into the iPlot visualization window in order to label 

the line plots with the names that were previously defined : 

 

20. Click on one of the line plots, hold down the Shift key, and click on the 

remaining two so that all 3 line plots are selected and highlighted. 

21. From the menu system, select “Insert > New  Legend”. 

22. Position the legend in the desired location in the upper-right hand corner of 

the viewplane. 

23. Click in a blank white area of the viewplane outside all graphical objects in 

order to deselect all objects. 

24. At this point, it may be a good idea to re-save the current state of the iPlot 

utility.  This can be accomplished by selecting “File > Save” from the menu 

system or hitting the Save  button. 

25. The current state of the IDL iPlot window should look similar to Fig. 13. 

 

 
 

Figure 13: The current state of the time-series line plot visualization 
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Operations, Graphical Output, and Printing 
 

So far the exercises in this chapter have demonstrated the data input, graphics 

creation, manipulation, undo/redo, and annotation capabilities of the iTools system.  

In addition to this standard functionality the iTools system also includes operations, 

which are data analysis and processing tools.  Any given iTool will contain a suite of 

the most common operations for the data type and visualization style that the utility 

was designed for. 

 

In the case of visualizing line plots of time-series data, one common operation that is 

performed in signal processing analysis is the application of a smoothing filter that 

will help eliminate some of the high-frequency noise contained within the data.  In 

addition, the user may be interested in obtaining mathematical statistics on the 

time-series datasets : 

 

1. Make sure the Select/Translate  arrow button is selected. 

2. Click on one of the line plots, hold down the Shift key, and click on the 

remaining two so that all 3 line plots are selected and highlighted. 

3. From the menu system, select “Operations > Filter > Smooth”.  A separate 

dialog window entitled “Smooth” will appear. 

4. This operation will apply a smoothing filter using a boxcar average over an 

area of a specified width.  Change the value for the “Width” field to “7” and 

press the “OK” button in the Smooth window.  Notice that the line plots are 

smoothed. 

5. Click within the white viewplane outside the graphics area in order to deselect 

all objects. 

6. Experiment with the Undo/Redo buttons the visualize the effect that the 

smoothing operation had on the line plot graphics. 

7. Reselect the three line plots by clicking on each while holding down the Shift 

key.  From the menu system, select “Operations > Statistics…”.  This will 

launch a separate window that displays the standard iTools statistics for each 

of the 3 line plot datasets [Fig. 14]. 

8. Once finished viewing the statistical information, close the iTools Statistics 

window. 
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Figure 14: Statistics for the time-series datasets 

 

At this point, it may be necessary to obtain a softcopy or hardcopy version of the 

current iPlot visualization.  There are a number of ways of exporting the current 

graphical visualization to the clipboard, image files on disk, or a printer : 

 

9. Make sure the Select/Translate  arrow button is selected. Click on an area 

outside the plot and drag a rectangle around the entire plot.  

10. Select “Edit > Copy”.  This will copy the current viewplane window to the 

native operating system clipboard so that it can be pasted into other software 

applications. 

11. If running on a Windows computer with Microsoft Office installed, open either 

Word or PowerPoint and paste the graphic into this separate application. 

 

In addition to the standard clipboard operations, the iTools system also offers the 

ability to export the current visualization to a wide variety of generic image formats : 

 

12. From the menu system, select “File > Export…”.  This will launch the IDL Data 

Export Wizard. 

13. In Step 1 of 3, select the “To a File” option for the export destination and hit 

the “Next >>” button. 

14. In Step 2 of 3, the user can select individual graphical objects to specify 

either the entire visualization or individual data items to export.  In this case, 

in order to output the entire visualization select the “Window” object and hit 

“Next >>”. 

15. In step 3 of 3 the output “File Type:” should be set to Windows Bitmap by 

default.  If this is not the case, select Windows Bitmap now. 
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16. Click the file selection  button and specify an output filename of 

“plot.bmp”. 

 

 
 

Figure 15: Specifying an output filename for Windows Bitmap format 

 

17. Once this is accomplished, hit the “Save” button in order to return to the IDL 

Data Export Wizard. 

18. The full path to the output file specified will be displayed within the “File 

Name:” field. 

19. Once this output filename is satisfactory, hit “Finish”. 

 

Looking within the output directory for the bitmap file that was just exported from 

the iPlot utility, the user should find a new file named “plot.bmp”.  Looking at this file 

in any standard image visualization software that can read and display bitmap files 

will display the contents of the iPlot visualization as it currently appears. 

 

The current iPlot visualization can also be sent directly to a printer for hardcopy 

output : 

 

20. Select “File > Print Preview…” from the main menu system. 

 

A separate Print Preview window will be displayed [Fig. 16].  This tool allows the user 

to control the layout of the iTools viewplane window in relation to a standard 8.5” x 

11” piece of paper.  Within the Print Preview window pane are horizontal and vertical 

offset bars, along with a scaling box. 
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21. Change the orientation droplist to “Landscape”. 

22. Click on the scaling box in the upper-right corner and move up or down to 

make the size of the graphic larger or smaller, respectively. 

23. Check the “Center” checkbox to automatically adjust the horizontal and 

vertical offsets so the graphic is centered within the page.  The user can also 

manually move the individual offset bars. 

24. If the computer being used is configured with a printer connection, the 

“Setup…” button can be pressed to obtain the standard printer selection / 

configuration dialog. 

25. In addition, if the computer being used is configured with a printer 

connection, the “Print” button can be pressed to direct output to the selected 

printer. 

 

 
 

Figure 16: The iTools Print Preview tool 

 

26. Once finished working with the Print Preview tool, press “Close”. 

27. At this point, the IDL iPlot window containing the time-series visualizations 

can be closed as it is no longer used from this point forward.  This can be 

accomplished by selecting “File > Exit” from the menu system or hitting the 

Close  button in the upper-right hand corner. 
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28. Restore the IDL Development Environment window so the IDL> command 

prompt can be accessed. 

 

 

 

Scatter, Histogram, Polar, and 3-Dimensional Plots 
 

In addition to standard 2-Dimensional line plots, IDL also has the capability to 

display X-Y scatter plots, histograms, polar plots, and 3-D line plots.  The iTools 

utilities can be launched with data automatically loaded using the arguments to the 

appropriate iTool procedure call.  Furthermore, the properties of the graphical 

objects can be controlled by using the keywords to the iTool procedure.  For 

example, create two 50 element vectors of uniformly-distributed, floating-point, 

pseudo-random numbers by using the RANDOMU function : 

 

1. IDL> x = RANDOMU (s, 50) 

2. IDL> y = RANDOMU (s, 50) 

 

The RANDOMU function returns two variables “x” and “y” that contain data values 
ranging from 0 � 1.0 that are created by a random number generator.  To visualize 

these two vectors in a X-Y scatter plot, simply load the variables as arguments to 

the IPLOT procedure and set the appropriate keywords in order to control the 

properties of the plot object.  In this example, the SCATTER keyword is set in order 

to change the graphic style from the default line plot to scatter plot mode, the 

SYM_INDEX keyword is set to the symbol index for small rectangular boxes, and the 

COLOR keyword is set to a RGB triplet for the color red : 

 

3. IDL> iPlot, x, y, /SCATTER, SYM_INDEX=6, COLOR=[255,0,0] 

 

This will launch a new IDL iPlot window containing a X-Y scatter plot of the random 

data values plotted as small red rectangles [Fig. 17]. 

 

4. It may help to click in the white viewplane outside of the graphics area to 

deselect the scatter plot object in order to remove the cyan selection 

markers. 

 
Note:  The appearance of the X-Y scatter plot that results may differ slightly from what appears in Fig. 17 
since the random numbers that are generated by the RANDOMU function will always be different. 

 

5. Once finished viewing the X-Y scatter plot, close the IDL iPlot window. 
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Figure 17: An X-Y scatter plot of the randomly generated numbers 

 

A histogram can also be useful for visualizing 2-Dimensional signals or a density 

plot showing a distribution of data values.  In a histogram plot, only horizontal and 

vertical lines are used to connect the plotted points.  For example, plot a simple sine 

wave using a histogram style plot : 

 

6. IDL> sine = SIN (FINDGEN (50) / 5) 

7. IDL> iPlot, sine, /HISTOGRAM, /FILL_BACK, FILL_COLOR=[255,0,0] 

 

The resulting IDL iPlot visualization window should look like Fig. 18. 

 

8. Once finished viewing the histogram plot, close the IDL iPlot window. 
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Figure 18: A histogram style plot of a sine wave 

 

So far all of the data that has been plotted is in a standard Cartesian (X-Y) 

coordinate system.  In some cases, the data may use a polar coordinate system, 

which involves radius distances measured at various angles (theta) that are 

expressed in units of radians.  For example, create a vector named “theta” that 

stores angles which encompass a full 360 degrees in 15° increments, and create a 
vector named “radius” that contains distances which range from 0 � 24 : 

 

9. IDL> theta = INDGEN (25) * 15 * !DTOR 

10. IDL> radius = FINDGEN (25) 

11. IDL> iPlot, radius, theta, /POLAR, XRANGE=[-24,24], $ 
                   YRANGE=[-24,24] 

 

The resulting IDL iPlot visualization window should look like Fig. 19. 

 

12. Once finished viewing the polar plot, close the IDL iPlot window. 
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Figure 19: A polar line plot of radius values that increase incrementally 

 

Finally, the iPlot utility is not limited to two dimensions, and quite often it is 

necessary to visualize datasets that have 3 variables (X, Y, Z) in three dimensions.  

For example, consider the flight test data that is stored in the file “flight_test.txt”.  

This example data file is located in the “data” subfolder. 

 

The file “flight_test.txt” contains standard ASCII text consisting of 3 columns of data 

separated by whitespace.  The first column contains longitude location in units of 

decimal degrees, the second column contains latitude position, and the third column 

contains the altitude of the aircraft.  Here are the first 2 lines of this ASCII text file : 

 
    Longitude     Latitude    Altitude (feet) 
     -97.3943      35.4237         798 

 

This flight test data will be loaded into a new iPlot utility in the same manner as the 

time-series data that was used in the previous exercise.  Start by launching a new 

blank IDL iPlot window : 

 

13. IDL> iPlot 

14. Select “File > Open…” from the menu system. 

15. Select the “flight_test.txt” file and hit “Open”. 
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16. In Step 1 of 3 for the ASCII Template wizard, make sure to change the “Data 

Starts at Line:” field to “2”. 

17. In the remaining steps of the ASCII Template wizard, all settings can be left 

as their defaults.  Simply hit “Next >>”, followed by “Finish”. 

18. In the IDL iTools Create Visualization dialog, press “Select a visualization and 

specify parameters” and hit “OK”.  This will display the Insert Visualization 

dialog. 

19. In the Select a Visualization row in the lower-left hand corner, click on “Plot” 

and change the graphic type droplist to “Plot3D” [Fig. 20]. 

20. Define the X parameter for the Plot3D visualization by clicking on “X” in the 

table in the lower-left corner, select the “flight_test.FIELD1” in the upper-left 

hand corner, then press the  down arrow button.  Do the same with 

“flight_test.FIELD2” as the Y parameter, and “flight_test.FIELD3” as the Z 

parameter [Fig. 20]. 

21. Once this is accomplished, hit “OK” to load the 3-Dimensional line plot. 

 

 
 

Figure 20: Specifying the parameters for the 3-D line plot 

 

The resulting IDL iPlot window should look like Fig. 21. 
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Figure 21: The 3-Dimensional line plot of flight test data 

 

All of the same translation, rotate, zoom, and scaling manipulators are available 

within the iTools system when a 3-Dimensional graphic is displayed, although they 

act in three dimensions. 

 

22. Once finished viewing the 3-Dimensional line plot, close the IDL iPlot window. 
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