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The IDL Intelligent Tools (iTools) 
 

The IDL Intelligent Tools (iTools) are a set of interactive utilities that combine data 

analysis and visualization with the ability to produce presentation quality graphics.  

The iTools allow users to continue to benefit from the control of a programming 

language, while enjoying the convenience of a point-and-click environment.  There 

are 7 primary iTool utilities built into the IDL software package.  Each of these seven 

tools is designed around a specific data or visualization type : 

 

• Two and three dimensional plots (line, scatter, polar, and histogram style) 

• Surface representations 

• Contours 

• Image displays 

• Mapping 

• Two dimensional vector flow fields 

• Volume visualizations 

 

The iTools system is built upon an object-oriented component framework 

architecture that is actually comprised of only a single tool, which adapts to handle 

the data that the user passes to it.  The pre-built iPlot, iSurface, iContour, iMap, 

iImage, iVector and iVolume procedures are simply shortcut configurations that 

facilitate ad hoc data analysis and visualization.  Each pre-built tool encapsulates the 

functionality (data operations, display manipulations, visualization types, etc.) 

required to handle its specific data type.  However, users are not constrained to work 

with a single data or visualization type within any given tool.  Instead, using the 

iTools system a user can combine multiple dataset visualization types into a single 

tool creating a hybrid that can provide complex, composite visualizations. 

 

 

 

Contouring a 2-Dimensional Dataset 
 

IDL has the ability to create contour plots of data stored in a rectangular 2-D array 

or a set of irregular unstructured points (X, Y, Z).  One of the most appropriate 

datasets that can be visualized with contours is a digital elevation model, or “DEM”, 

which is a gridded 2-D matrix of elevation values that define the topography for a 

region.  In the following exercise, DEM data for the Grand Canyon in Arizona will be 

displayed within the iContour utility.  This example data is stored in a file named 

“Grand_Canyon_DEM.tif” that is located in the “data” subfolder. 

 

Although the file “Grand_Canyon_DEM.tif” is in TIFF image format, the pixels of this 

dataset contain actual elevation data values in units of meters.  Use the following 

steps to load this dataset into the iContour utility : 

 

1. IDL> iContour 

2. Select “File > Open…” from the IDL iContour window. 

3. Select the “Grand_Canyon_DEM.tif” file and hit “Open”. 

4. A contour graphical object with the default properties will be automatically 

inserted into the IDL iContour window. 
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5. It may help to maximize the iTool window in order to see the graphic, so 

select “Window > Zoom on Resize” from the menu system and maximize the 

IDL iContour window. 

6. Select the contour plot object, right-click, and select “Properties…”. 

7. Within the Visualization Browser window, click on the box to the right of the 

“Levels color table” property and select “Edit…” [Fig. 1]. 

8. A separate dialog entitled Palette Editor will be displayed.  In the “Load 

Predefined…” droplist, select the “RAINBOW” color table. 

9. Press “OK” to dismiss the Palette Editor window. 

10. At this point the IDL iContour window will be brought to the foreground.  

Relocate the Visualization Browser window, which may be behind the IDL 

iContour window.  Change the “Number of levels” property to a value of “10”, 

hit Enter on the keyboard to complete the change, and close the Visualization 

Browser window [Fig. 1]. 

 

The DEM data for the Grand Canyon should now be displayed with a sequence of 

color contours that resembles a topographic map.  The elevation at which the 

contours are drawn are automatically computed by dividing the data value range 

(minimum to maximum) into 10 evenly sized levels.  The exact elevation for any 

given contour, and all other relevant properties, can also be modified by the user if 

necessary. 

 

 
 

Figure 1: Modifying the properties of the contour plot 

 

The iTools system also have built-in tools for inserting a colorbar and legend for a 

contour plot graphic : 

 

11. Make sure the contour plot is selected. 

12. Select “Insert > Colorbar”.  A colorbar showing the color table and range of 

elevations is automatically inserted below the graphics area. 
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13. Reselect the contour plot. 

14. Select “Insert > New Legend”.  Re-position the legend that is inserted in the 

upper-right hand corner. 

 

The final IDL iContour window should appear like Fig. 2. 

 

15. Once finished viewing the contour plot visualization, close the IDL iContour 

window. 

 

 
 

Figure 2: Contour plot visualization of DEM data for the Grand Canyon 

 

 

 

Creating a Surface from a 2-Dimensional Dataset 
 

A surface representation provides a way to visualize a gridded 2-Dimensional array 

of data values as a 3-Dimensional object.  The height of the surface at any given X-Y 

location is defined by the data value (Z).  In some cases, the 2-Dimensional data 

may be in the form of 3 unstructured (X, Y, Z) vectors instead of a gridded matrix.  

For example, elevation data is quite often measured and stored in irregular X-Y-Z 

format.  In order to visualize this type of data as a surface graphical object, the data 
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must first be gridded using an interpolation algorithm that converts the scattered 

data values into a 2-Dimensional array.  Fortunately, the iTools system has a built-in 

Gridding Wizard to help walk the user through the process of gridding irregular X-Y-Z 

data. 

 

In the following exercise, the X-Y-Z data from the example data file “elevation.txt” 

will be input into the iSurface utility.  This example data file is located in the “data” 

subfolder. 

 

The file “elevation.txt” contains standard ASCII text consisting of 3 columns of data 

separated by commas.  The first column contains the longitude position, the second 

column contains latitude, and the third stores the elevation data values.  Here are 

the first 2 lines of this ASCII text file : 

 
Longitude,Latitude,Elevation 

-136.049,59.3303,3537 

 

Use the following steps in order to load the data from the file “elevation.txt” into the 

iSurface utility : 

 

1. IDL> iSurface 

2. Select “File > Open…” from the menu system. 

3. Select the “elevation.txt” file and hit “Open”. 

4. In Step 1 of 3 for the ASCII Template wizard, make sure to change the “Data 

Starts at Line:” field to “2”. 

5. In the remaining steps of the ASCII Template wizard, all settings can be left 

as their defaults.  Simply hit “Next >>”, followed by “Finish”.  There may be a 

short delay while IDL ingests the data from this ASCII text file. 

6. In the IDL iTools Create Visualization dialog, select “Launch the gridding 

wizard” and press “OK”. 

7. The IDL Gridding Wizard window will appear.  In Step 1 of 3, the wizard 

describes the data that was input and displays a preview of the resulting 2-

Dimensional grid.  Confirm that this dialog appears as it does in Fig. 3 and hit 

“Next >>”. 

8. In Step 2 of 3, change the “Dimension:” parameter for both the “X 

coordinates:” and “Y coordinates:” from the default setting of “25” to “500” 

[Fig. 4] and hit “Next >>”. 

9. In Step 3 of 3, change the “Please choose a gridding method:” droplist setting 

to “Linear” [Fig. 5] and hit “Finish”. 
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Figure 3: Step 1 of 3 for the IDL Gridding Wizard 

 

 

 

Figure 4: Step 2 of 3 for the IDL Gridding Wizard 
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Figure 5: Step 3 of 3 for the IDL Gridding Wizard 

 

After the IDL Gridding Wizard is completed, the selected gridding and interpolation 

algorithm is used to convert the unstructured X-Y-Z data into a 2-Dimensional grid.  

Once this processing is finished, a surface object for the elevation data will be 

displayed within the IDL iSurface window [Fig. 6].  At this point, it may be beneficial 

to maximize the iSurface utility : 

 

10. From the IDL iSurface window menu system, select “Window > Zoom on 

Resize”. 

11. Maximize the IDL iSurface window. 
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Figure 6: Surface visualization of the X-Y-Z format elevation data 

 

 

 

Manipulating 3-Dimensional Graphical Objects 
 

The object selection, translation, view zoom, undo/redo, and annotation tools all 

behave in the same exact manner as they do in 2-Dimensional graphics mode.  

However, when an iTool is displaying a 3-Dimensional graphical object, the scaling 

and rotate manipulators behave in a slightly different fashion. 

 

There are 3 types of scaling available for 3-D objects : 

 

• Constrained Scaling 

o Multiple-Axis Scaling (  mouse pointer) 

o Single-Axis Scaling (  mouse pointer) 

• Unconstrained Scaling (  mouse pointer) 

 

The multiple-axis scaling mouse pointer for 3-D objects is obtained when the 

mouse pointer is positioned over a corner of a 3-D object’s data space.  Dragging the 

constrained scaling pointer scales the object a fixed distance along all axes in the 
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direction of the drag.  In contrast, the single-axis scaling is accessed when the 

mouse pointer is positioned over an axis “whisker”, which are small linear hash 

marks on the edges of the data space in the direction of the three orthogonal axes.  

Dragging along an axis whisker scales the object only in the direction of the axis 

(and the arrows of the mouse pointer).  Finally, unconstrained scaling of 3-D objects 

can be performed when a single side of the data space bounding box is dragged, 

scaling the object along the dimensions of the selected side. 

 

1. Experiment with the 3 different styles of scaling with the 3-D surface object 

within the IDL iSurface window. 

2. Use the single-axis constrained scaling along the Z-dimension whisker to 

adjust the vertical exaggeration of the surface object.  It may be appropriate 

to reduce the vertical exaggeration in order to make a more realistic 

visualization of the terrain. 

3. If at any time an undesirable scaling operation is performed, remember that 

the Undo tool can be used to reverse the operation. 

 

The rotation of 3-D objects in the iTools system can be done in a freehand 

(unconstrained) fashion or constrained along each of the three orthogonal axes.  

When a 3-D object is selected within rotation mode, a rotation sphere consisting of 

circular X, Y, and Z dimension axes is displayed around the object.  To rotate an 

object in a constrained fashion, position the mouse cursor over one of the three axis 

circles in the rotation sphere until the cursor changes to a constrained rotation  

pointer and drag in the desired direction.  To rotate an object in an freehand fashion 

simply position the mouse pointer anywhere on the object until the cursor changes 

to an unconstrained rotation  pointer and drag in any arbitrary direction. 

 

4. Experiment with both constrained and freehand rotation of the 3-D surface 

object. 

 

 

 

Adding Contours and a Texture Map 
 

One of the benefits of the object-oriented design of the iTools system is the ability to 

make composite visualizations that include more than one graphic.  The data that is 

currently being used to define the surface graphical object is digital elevation data, 

and as the previous exercise demonstrated it is quite appropriate to visualize DEM 

data using a contour plot.  Fortunately, the iTools has a built-in operation that allows 

the user to automatically add contours to the current visualization utility. 

 

1. Using the Select/Translate  arrow, select the surface object within the IDL 

iSurface window. 

2. While the surface object is highlighted, select “Operations > Contour” from 

the menu system.  The Contour dialog will appear [Fig. 7]. 

3. Within the Contour dialog, change the “Number of levels” parameter to “20” 

[Fig. 7]. 

4. Click in the box to the right of “Projection” parameter and change its setting 

to “Three-D” [Fig. 7]. 

5. Once these changes have been made, press the “OK” button.  This will insert 

the contour graphical object within the same iSurface utility as the existing 

surface object. 



   

   

ITT Visual Information Solutions • 4990 Pearl East Circle Boulder, CO 80301 
P: 303.786.9900 • F: 303.786.9909 • www.ittvis.com 

Page 10 of 13 

 

 
 

Figure 7: Options when inserting a contour visualization 

 

In order to get a better view of these contours, it may be beneficial to change their 

color so it contrasts with the surface. 

 

6. Select “Window > Visualization Browser…” from the menu system. 

7. Make sure the Contour object is selected.  Within the property sheet along the 

right-hand side, click on the box to the right of the “Contour level properties” 

item and select “Edit…”. 

8. A separate window entitled “Contour Levels” will appear.  The first column of 

this dialog can be used to adjust the properties of all of the contours.  Change 

the “Color” property for “All Levels” to bright blue and hit “OK” to dismiss this 

dialog. 

9. Close the Visualization Browser window. 

 

The resulting visualization should look similar to Fig. 8. 
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Figure 8: Surface with contours draped on top 

 

In addition to the ability to drape contours on top of a surface, IDL also has the 

capability to drape images on top of 3-Dimensional graphical objects.  This 

visualization technique involves the use of what’s known as a texture map. 

 

The example “data” subfolder for this tutorial contains a PNG image file of a satellite 

image that covers the same exact area as the elevation data.  This image can be 

draped on top of the surface as a texture map using the following steps : 

 

10. First, remove the contours so they will not hinder the display of the texture 

map image.  This can be accomplished by opening the Visualization Browser, 

right-click on the Contour object, and select “Delete”. 

11. Close the Visualization Browser window. 

12. Within the IDL iSurface window select the surface object, right-click, and 

select “Parameters…”. 

 

The Parameter Editor dialog will appear.  In the lower-left hand corner the 

parameters that define the current surface object are listed.  Currently, only the “Z”, 

“X”, and “Y” parameters has been defined using the elevation data.  Notice that there 

is also a parameter called “TEXTURE”, and it is this parameter that can be used to 
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specify a texture map image to drape on top of the surface.  However, the 

“satellite.png” file must first be opened and input into the iTools system. 

 

13. From the Parameter Editor window, press the “Import File…” button.  This will 

launch the File Import dialog. 

14. Within the File Import dialog, press the file selection  button, navigate to 

the appropriate location, select the file “satellite.png” and hit “Open”. 

15. Once this file is selected, the File Import wizard should recognize the format 

as being “Portable Network Graphics”. 

16. Hit “OK” to dismiss the File Import dialog. 

17. Back within the Parameter Editor, expand the new “satellite.png” image item 

so the “Image Planes” contained within are visible.  This image is in 24-bit 

RGB true color mode, so it has 3 image planes. 

18. Select the “Texture” row located in the lower-left table, and then double-click 

the “Image Planes” from the Data Manager in the upper-left corner of the 

window in order to load this image as the surface’s texture map [Fig. 9]. 

19. Once this is accomplished, press “Apply” followed by “Dismiss” to complete 

the changes. 

 

The resulting visualization should look similar to Fig. 10. 

 

 
 

Figure 9: Using the satellite image to define a texture map 

 



   

   

ITT Visual Information Solutions • 4990 Pearl East Circle Boulder, CO 80301 
P: 303.786.9900 • F: 303.786.9909 • www.ittvis.com 

Page 13 of 13 

 
 

Figure 10: Surface with texture map draped on top 

 

20. Once finished viewing the surface visualization, close the IDL iSurface utility. 
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